By default when configuring OSPF on a Mikrotik router, it will be a broadcast network type. This will work for most situations, but it uses multicasting to communicate with other ospf nodes on the network segment. For this reason it is recommended to use network type NBMA or Non Broadcast Multi Access for wireless network segments. This requires more configuration, such as specifying the neighbors manually and setting priorities.
The reason NBMA is recommended is because in 802.11 wireless networks multicast packets are not always reliably delivered (read Multicast in wireless networks for details); using multicast here can create OSPF stability problems.
Neighbors are created dynamically when you specify broadcast as the network type. If you create an NBMA neighbor and add a new OSPF interface with network type NBMA, then this will take place of the broadcast neighbor configuration.
Example configuration (from MikroTik wiki)
1. Specify the nbma neighbors and the network. On all routers do the following:
/routing ospf network
add network=10.1.1.0/24 area=backbone
/routing ospf nbma-neighbor
add address=10.1.1.1 priority=0
add address=10.1.1.2 priority=0
add address=10.1.1.3 priority=1
add address=10.1.1.4 priority=1
2. Configure the interface priorities. On router A and B specify priority 0 so they don't become DRs
/routing ospf interface
add interface=ether1 network-type=nbma priority=0
Make the priority > 0 for the other 2 routers. Priorities can be between 0 and 255
The reason NBMA is recommended is because in 802.11 wireless networks multicast packets are not always reliably delivered (read Multicast in wireless networks for details); using multicast here can create OSPF stability problems.
Neighbors are created dynamically when you specify broadcast as the network type. If you create an NBMA neighbor and add a new OSPF interface with network type NBMA, then this will take place of the broadcast neighbor configuration.
Example configuration (from MikroTik wiki)
1. Specify the nbma neighbors and the network. On all routers do the following:
/routing ospf network
add network=10.1.1.0/24 area=backbone
/routing ospf nbma-neighbor
add address=10.1.1.1 priority=0
add address=10.1.1.2 priority=0
add address=10.1.1.3 priority=1
add address=10.1.1.4 priority=1
2. Configure the interface priorities. On router A and B specify priority 0 so they don't become DRs
/routing ospf interface
add interface=ether1 network-type=nbma priority=0
Make the priority > 0 for the other 2 routers. Priorities can be between 0 and 255
/routing ospf interface
add interface=ether1 network-type=nbma priority=1
The routers will form adjacencies and start exchanging LSAs. To verify:
/routing ospf neighbor print
You should see 'Full' adjacencies between each of the DRs (routers C and D) and the others.
Comments
Post a Comment