Skip to main content

Vlans over wireless link


Take this scenario.

We want the laptops on vlan 100 and the PCs on vlan 200. We don't want communication between vlans. Here is how it would go, assuming the wds link is configured and working.

1. create the vlan interfaces

/interface vlan
add name=vl-laptops-wds1 vlan-id=100 interface=wds1 disabled=no
add name=vl-pc-wds1 vlan-id=200 interface=wds1 disabled=no

Note that the name of the vlan interfaces can be what you like, but you should make it something that makes sense. I usually name mine in the above convention - vl for VLAN, followed by the name / use of the vlan, followed by the physical interface.

2. create the bridges and add the vlans

/interface bridge
add name=laptops
add name=pcs

/interface bridge port
add interface=vl-laptops-wds1 bridge=laptops
add interface=vl-pc-wds1 bridge=pcs

Note: leave the physical interface out of any bridges (in this case wds1)

3. add the ether interfaces to the appropriate vlans. In this scenario, E1 to laptop vlan and E2 for PCs

/interface bridge
add interface=ether1 bridge=laptops
add interface=ether2 bridge=pcs


Thats it! you have both vlans being tagged over the wds link. Happy vlanning.

Comments

Popular posts from this blog

DHCP option 121

http://tools.ietf.org/html/rfc3442 This is used to add a classless  static route to the DHCP clients. To add option 121 to a Mikrotik DHCP server, it's value is specified in HEX. The format is as follows. 0xnnddddddddgggggggg where n=mask, d=destination, g=gateway. To convert ip address to HEX, you convert each octet, so 192=C0, 168=A8, 55=37, 1=01 You can use a tool such as  http://www.miniwebtool.com/ip-address-to-hex-converter/?ip=192.168.55.1 Example: To add a route to the destination network of 192.168.55.0/24 via gateway 172.16.10.1. /ip dhcp-server option add name=classlessroutes code=121 value=0x18C0A837AC100A01 where 18 is 24 in hex. *note: depending on the subnet mask, you may only need to specify 0-4 octets. In fact only the non-zero, or network portion of the subnet. Here is a table from the RFC. subnet mask Number of octets 0 0 1- 8 1

Mikrotik Bridge Horizon

To achieve similar functionality to Cisco's private VLANS, where all ports are on the same L2 segment, but cannot exchange packets, you can use Mikrotik's Bridge Horizon feature. Basically, every port in a bridge is assigned a horizon value, and RouterOS will only forward frames to other interfaces in the bridge that have different horizon values. This means that you assign the same horizon value to the interfaces that you don't want to be able to communicate. For example, you want to bridge all your customers and use a single /24 subnet and the same gateway. Typically this is bad and poses a huge security risk, not to mention performance issues. If you assign the same horizon value to the customer interfaces, then the router will not forward traffic between customers. Customer A will not be able to ping Customer B. If you had a server, such as an IP-PBX that all customers needed to access, and you were lazy and added it to the bridge, then you would assign a diff

Mikrotik mac address filtering

Playing with an RB493G and wanted to allow only a certain list of mac addresses to be able to connect. We all know this type of security is in no way fool proof. The 493G has 2 switch chips in it and ports 2-5 are on switch2 and ports 1 and 6-9 are on switch1 Much like /ip firewall filter rules, switch rules are checked chronologically (top down). And like /ip firewall filter rules, you must specify a deny rule. Although there is no 'deny' rule as such, you can just specify a redirect to null (specify no port) which achieves the same result.