10 September 2012

Mikrotik Dot Q-in-Q

How to create a Q-in-Q or 802.1ad double-tagged interface on a Mikrotik Router:

Stripped down 802.1ad packet:

DST-MAC | SRC-MAC | 802.1Q outer | 802.1Q inner |  PAYLOAD


/interface vlan 
add interface=ether1 name=outervlan vlan-id=600
add interface=outervlan name=innervlan vlanid=1500

The router will strip the outer vlan tag to expose the inner vlan. vlan 1500 is essentially tunnelled using the outer vlan (600) across the provider network.



No comments:

Post a Comment